Jump to content
Rocco_Fist

Uptime

Empfohlener Beitrag

Rocco_Fist
Geschrieben

Ich fände es toll wenn ihr etwas an eurer Uptime machen würdet.

In den letzten Tagen kommt es häufig zu folgenden Fehlern:

503 Gateway Timeout

Es ist ein Fehler aufgetreten, bitte versuche es nochmal.

Bitte hab einen
Moment Geduld.
Die Anfrage
wird bearbeitet.


Der Server unter www.poppen.de braucht zu lange, um eine Antwort zu senden.

Die Website könnte vorübergehend nicht erreichbar sein, versuchen Sie es bitte später nochmals.


Trestertester
Geschrieben

Du hast doch sicherlich auch die Informationen über die Probleme der Verbindung in den letzten Tagen auf der Startseite gelesen, oder?


Rocco_Fist
Geschrieben

Zwischendurch stand mal was von einer abgeschmierten Datenbank da. Sowas passiert schon mal, kein Problem.

Insgesamt gesehen häuft es sich leider und wenn man bezahlt, möchte man schon etwas mehr Verfügbarkeit. Gerade mobil hat man sehr viel Gateway Timeouts.

Als Stichwort für die Zukunft vielleicht mal "Elastic Cloud". Wenn man das richtig macht, kann man Diskimages der laufenden Maschinen nehmen und portieren.


Ajou
Geschrieben

Kommt auch öfters mal vor, dass die Seite nicht vollständig geladen werden. Dann bleiben die Bilder in den Profilen weiß und man sieht nichts. Hängt schätze ich auch damit zusammen. Ist denke ich vor allem dann so, wenn viele Leute hier auf poppen.de online sind?


Rocco_Fist
Geschrieben

Dann bleiben die Bilder in den Profilen weiß und man sieht nichts.



poppen.de läuft über mindestens sechs IP-Adressen,die zudem in verschiedenen Netzwerken liegen. Vermutlich stehen auch mehrere Server, zumindest logisch dahinter.

Verschiedene Netzwerke an sich können durch anliegenden Traffic schon völlig unterschiedliche Latenzzeiten haben.

In deinem Fall sind es evtl. zwei logische Server, die unter dem Namen bilder.poppen.de laufen und auf denen die Bilder gehostet werden. (Zumindest verweisen zwei IP Adressen auf den Server [x.x.151.25 und x.x.151.26])

Die beiden, oder der für die Bilder zuständige Server ist dann einfach überlastet, oder hat irgendein Problem. Wobei es schon sinnvoll ist verschiedene Dienste bei so einem großen Portal zu trennen.


Geschrieben (bearbeitet)

@XtraPlus

Nach meinem Wissen ist das alles richtig, was Du sagst.

Nur, warum habe ich dann dieses Problem nicht?

Muss dann wohl doch ein abhängiges individuelles system- u. softwarebedingtes User-Provider-Betreiber-Problem sein.

Es ist daher nicht der richtige Ansatz zu sagen, die Seite hat ein Uptime-Problem, Überlast, etc.In erster Linie hast Du ein Problem, welches auch immer. Ich jedenfalls habe nicht das geringste Uptime-Prob mit der Seite. Dieses Prob scheint es auch nur vereinzelt zu geben. Was meinst Du, wie heiß hier Threads laufen würden, wenn es tatsächlich ein generelles Prob wäre. Insofern würde ich mich mit Deinem Prob an den Support wenden, um eine individuelle Lösung für Dich zu finden.


bearbeitet von Honolulu004
Geschrieben (bearbeitet)

Kommt auch öfters mal vor, dass die Seite nicht vollständig geladen werden. Dann bleiben die Bilder in den Profilen weiß und man sieht nichts.


In erster Linie hast Du ein Problem, welches auch immer. Ich jedenfalls habe nicht das geringste Uptime-Prob mit der Seite.


ICH habe dieses Problem ebenfalls, und zwar ausschließlich bei poppen.de. Alle anderen Websites funktionieren ganz, ganz erheblich weniger störungsanfällig. Das mache ich nicht zu meinem Problem, sondern zum Problem der Betreiber. Auch weiß ich aus meiner bisherigen Korrespondenz hier, dass es sich wohl nicht um Einzelfälle handeln wird. Der Support schiebt es dennoch auf den jeweiligen Rechner, an dem der User sich gerade befindet.

Von Technik habe ich null Ahnung, aber meine funktioniert ansonsten reibungslos. Soll ich meinen Rechner nun poppen.de-spezifisch optimieren oder lieber so, dass alles andere läuft wie gewohnt?


bearbeitet von Mehlbox
Schlüppadieb
Geschrieben

Ich denke aber schon, das es eher in die richtung geht, die Honolulu004 beschrieben hat. Wenn 5 % ein Problem haben, dürfte die Ursache möglicherweise wo anders zu suchen sein, als wenn 95 % das Problem haben.

Ich habe auch keinerlei Probleme ( von gelegentlichen weißen Bildern abgesehen. )

Es gibt ja einige mögliche Ursachen, die irgendwo zwischen Server und PC liegen können.


Geschrieben

Poppen.de macht nur einen geringen Bruchteil der Seiten aus, die ich regelmäßig nutze. Alle anderen Websites laufen einwandfrei(!), ergo suche ich nicht bei mir.

"Gelegentlich weiße Bilder" heißt bei mir "täglich weiße Bilder", unabhängig vom zeitlichen und mengenmäßigen Umfang der Bildausfälle. Selbst die Platzhalter "kein Bild Vorhanden" werden teilweise nicht geladen. Mein Problem? Sicherlich nicht eins was auf meinem Rechner liegt, sondern eher eins in der Frage, ob und wie ich mich zukünftig in Sachen poppen.de und Mitgliedschaft entscheiden werde, vor allem in Bezug auf sonstige Ausfälle, die ja nun auch nicht an meiner Technik liegen dürften.


Schlüppadieb
Geschrieben

Alle anderen Websites laufen einwandfrei(!), ergo suche ich nicht bei mir.



versuch es einfach noch mal mit meinem letzten Satz.

Es gibt ja einige mögliche Ursachen, die irgendwo zwischen Server und PC liegen können.



Der Weg der Daten zum PC geht einige Stationen, auf die der Betreiber keinen Einfluss hat.

Ich habe beispielsweise DSL 16.000 und trotzdem habe ich gelegentlich Downloads, die mich eher an Modemzeiten erinnern.


Geschrieben (bearbeitet)

versuch es einfach noch mal mit meinem letzten Satz.

Ach, ich nehme dann lieber deinen ersten Satz

Ich denke aber schon, das es eher in die richtung geht, die Honolulu004 beschrieben hat.

der also auf ein Problem des Users hinweist.



edit:
ich habe übrigens die Angewohnheit, nicht jeden Teil meiner Antworten auf das Vorposting zu beziehen.


bearbeitet von Mehlbox
Geschrieben (bearbeitet)

@Mehlbox

Wie @XtraPlus ja ganz richtig sagt, geht diese Seite über mehrere und ganz bestimmte IP-Adressen, mehr und besonders, als auf anderen Seiten üblich. Dies scheint bei bestimmten Konfigurationen zu Problemen zu führen. Auf Seiten des User bedingt es vielleicht eine Änderung bestimmter Parameter in den Internet-Einstellungen. Vielleicht wird diese Störung durch bestimmte Software und ihrer Konfiguration ausgelöst, vielleicht liegt das Problem aber auch nur an der User-Provider-Abhängigkeit, sprich, bestimmte Provider machen etwas anders, als andere Provider.

Wie ich hier in anderen Threads gelesen habe, gibt es insbesondere immer dann ein Problem in diesem Zusammenhang, wenn Opera als Browser genutzt wird. Es wird berichtet, bei anderen Browsern funktioniert es zwar besser, aber auch nicht einwandfrei. Schon daran erkennst Du, dass es tatsächlich sehr individuell zu lösen ist. Und wenn ich keine Probleme in dieser Hinsicht habe, mag es doch meine These individueller Config-Probleme unterstreichen, oder wie erklärst Du Dir, dass ich dies Problem nicht habe?

Dabei ist es unerheblich, ob Du auf anderen Seiten diese Probleme nicht hast, da diese eher gängige Verbindungen haben. Wie gesagt, die Verbindung zu p.de ist schon sehr speziell, woraus sich wohl dieses Problem allgemein ergibt.

P.S. Eine Annahme von mir ist noch, dass es unter Einbeziehung vorgenannter Punkte auch mit 32-bit - 64-bit - Systemen zu tun haben könnte.


bearbeitet von Honolulu004
Geschrieben

Keine Exoten, keine Experimente auf meinem Rechner!

Also ich benutze einen absolut gängigen Browser (Firefox) in der aktuellsten Version mit keineswegs exotischen AddOns, PlugIns, Änderungen in den Netzwerkeinstellung oder ähnlich, ausschließlich "pupnormale" Software, mein Provider aus Bonn sollte auch kein Grund für Störungen sein (denn dann hätten diese Probleme SEHR viele), Rechner und Betriebssystem geben mir ebenfalls keinen Anlass zum Nachdenken, meine Downloadgeschwindigkeit schon gleich gar nicht. Bis auf poppen.de läuft bei mir ALLES reibungslos.

Ich wiederhole mich hier nur ungern, aber bei mir suche ich die Probleme nicht. Dabei ist es mir auch egal, ob (viele) andere keine Probleme haben und wie deren Konfiguration aussieht. Bis auf poppen.de läuft bei mir ALLES reibungslos.

Tatsache ist eben, dass poppen.de (nicht nur bei mir) Probleme macht, andere Seiten hingegen nicht. Deshalb werde ich an meinem Rechner sicher nichts ändern und jetzt auch nicht weiter darüber nachdenken.

Poppen.de kennt die Probleme und sollte sich den Kunden anpassen, nicht umgekehrt. Und es sei noch einmal erwähnt, dass diese Seite regelmäßig mit anderen (Server bedingten) Problemen zu kämpfen hat, wie man ja im Forum und im Blog nachlesen kann, die ich von anderer Seite noch nicht so wahrnehmen konnte. Nicht mein Problem! Ist/sind ja nich' mein(e) Server.


Wie gesagt, die Verbindung zu p.de ist schon sehr speziell

und das eben kann ja nur poppen.de lösen.


Geschrieben

Hier und da wird es sicher ein Problem mit dem benutzten Rechner geben, als dem Rechner des Seitenbenutzers.
Kann auch, selbst wenn es de aus Bonn ist, ein Teil beim Provider liegen (der aus Bonn z.B. verzögert bestimmte Server ganz bewusst).

Das Hauptproblem ist aber sicher beim Seitenanbieter zu suchen. Die Ursachen sind da mehr als vielfälltig und nicht ganz so einfach wohl auf den Punkt zu bringen. Vor allem mit dem was man von aussen so weiss und was so als Problem kundgetan wird.
Zum einen sind es bei p.de ja einige Server, die die Seite darstellen. Zum Zweiten hängt eine Software (nginx) vor den Server, die wohl ein richtig nettes Sensibelchen ist. Zum Dritten dann noch die Sache mit den Zugriffsrechten. Nämlich wem was gezeigt werden darf/kann. Damit sind nicht die Verzeichnisrechte auf den Servern gemeint, sondern die, die vom System gesetzt werden. Last but not least sind dann noch die Kleinigkeiten wie Java und Konsorten zu berücksichtigen. Da dürfte wohl das Opera-Problem zu suchen sein, der darin ziemlich strikt ist.
Wäre also von Seiten des Betreibers mal ganz gut intensive Fehlersuche zu machen bevor es immer wieder Änderungen gibt. Könnte sogar mittlerweile eher sinnvoll sein, alles mal von Grund auf neu aufzusetzen um alle Reste und Leichen wegzubekommen und sauberen aktuellen Code zu bekommen.

Ich selbst greife über 5 (teils ganz verschieden konigurierte) Rechner auf die Seite. Manche Probleme haben alle, manche Probs nur bestimmte. Einer ohne ist nicht dabei. An den rechnern allein kann es nicht liegen, da sich die Fehler in ihrer Häufigkeit nach Zeit ändern. Spricht eher für ein Serverproblem wieder.


Rocco_Fist
Geschrieben (bearbeitet)

@XtraPlus
Muss dann wohl doch ein abhängiges individuelles system- u. softwarebedingtes User-Provider-Betreiber-Problem sein.



Ich hab durchschnittlich sieben bis acht Tabs offen, in denen es zur selben Zeit flüssig läuft, bei gleichen Seitengrößen. Egal, ob Opera, Firefox, IE, Epiphany, etc... Verschiedene Maschinen und Betriebssysteme, Win7, Ubuntu, Debian, Mint. Nichtmal die Fritzbox kann es sein, weil ich zeitweise auch USB-Sticks, oder Tethering nutze.

Allerdings spielen Provider und einige andere Dinge eine nicht zu unterschätzende Rolle.

Um da tatsächlich was zu sagen, müsste man sachliche verschiedene Routen testen.

Letztendlich hakt es schon an der Verfügbarkeit. Wünschenswert wäre halt wenn so etwas kurzfristig lösbar wäre.


@Mehlbox
Wie @XtraPlus ja ganz richtig sagt, geht diese Seite über mehrere und ganz bestimmte IP-Adressen, mehr und besonders, als auf anderen Seiten üblich.



Das kann man schon auf mehrere verteilen.

Bilder werden häufig aus dem Dateisystem geholt, gerade Userbilder müssen bei jedem Profilbesuch rausgekramt werden. Datenbankabfragen gehen an einen SQL-Server. etc...

Für jede dieser Aufgaben kann man Server speziell einrichten, sogar speziell ausgelegte Dateisysteme wählen, etc.

Allerdings wird es schwierig, wenn zB der kanonische Name bilder.poppen.de zwei IP Adressen hat. Da kann es tatsächlich Konfigurationen geben, in denen der Client nicht weiss, von welcher er nun Bilder holen soll.


Kann auch, selbst wenn es de aus Bonn ist, ein Teil beim Provider liegen (der aus Bonn z.B. verzögert bestimmte Server ganz bewusst).

Ich selbst greife über 5 (teils ganz verschieden konigurierte) Rechner auf die Seite. Manche Probleme haben alle, manche Probs nur bestimmte. Einer ohne ist nicht dabei. An den rechnern allein kann es nicht liegen, da sich die Fehler in ihrer Häufigkeit nach Zeit ändern. Spricht eher für ein Serverproblem wieder.



Routing und bewusste Bremsen scheinen ein sehr dickes Problem speziell bei poppen.de zu sein. Allerdings müsste man das nachweisen.

Ansonsten sehe ich da auch eher eine vermutlich gewachsene, Soft. - und Hardwarelandschaft, die in der Form den Aufgaben nicht gewachsen ist.


bearbeitet von XtraPlus
×